Install Google Earth on Ubuntu 16.04

UPDATE 2016-09-07

Google has a new release of Google Earth on Aug. 25 2016 which make the installation on Ubuntu so much easier. No more fix and work-around needed! (Thanks Martin posted this great news.)

So I tried it on Ubuntu 16.04.1 and it just works.

For new installation, download the .deb file from Google, then simply run

sudo apt-get install lsb-core
sudo dpkg -i google-earth-stable_current_amd64.deb

If you have the previous version of GE installed, then remove it first:

sudo dpkg -P google-earth-stable
sudo rm -rf /opt/google/earth/free

After this you should get a working Google Earth version

The following is my old post back in April and I keep it here just for references.

Ubuntu 16.04 LTS (Xenial Xerus) just released last week. I was testing it and had trouble to install Google Earth on it just like previous version of Ubuntu.

My system is 64 bit Ubuntu 16.04. The big problem is Ubuntu missing all the “lsb-*” packages which Google Earth depend on. After few hours trial-and-error, finally I have the Google Earth running normally on my notebook.

UPDATE (July 15 2016)
Today I tried to install Google Earth on a brand new ASUS Zenbook, I hit trouble when I try to install these “lsb-*” packages. After check around I see that Ubuntu now has brought back these packages to its repository.

So for the “lsb packages” section below, all I need to do it install “lsb-core” (apt-get install lsb-core).

Here is how to install:

Install dependences

First install these packages:

sudo apt-get update
sudo apt-get install libgstreamer0.10-dev libgstreamer-plugins-base0.10-dev flashplugin-installer libfreeimage3 libc6:i386

lsb packages

Install lsb-core:

sudo apt-get install lsb-core

Check the “lsb-*” packages:

$ dpkg -l | grep lsb
ii lsb-base 9.20160110ubuntu0.2 all Linux Standard Base init script functionality
ii lsb-core 9.20160110ubuntu0.2 amd64 Linux Standard Base core support package
ii lsb-invalid-mta 9.20160110ubuntu0.2 all Linux Standard Base sendmail dummy
ii lsb-release 9.20160110ubuntu0.2 all Linux Standard Base version reporting utility
ii lsb-security 9.20160110ubuntu0.2 amd64 Linux Standard Base Security package

lsb packages (Out dated!)

I have to manually install three lsb packages: lsb-core, lsb-security and lsb-invalid-mta
Download the packages first:

mkdir ~/lsb
cd ~/lsb

Try to insall these packages

sudo dpkg -i *.deb

Here I saw some error output like this:

$ sudo dpkg -i *.deb
Selecting previously unselected package lsb-core.
(Reading database ... 176877 files and directories currently installed.)
Preparing to unpack lsb-core_4.1+Debian11ubuntu6_amd64.deb ...
Unpacking lsb-core (4.1+Debian11ubuntu6) ...
Selecting previously unselected package lsb-security.
Preparing to unpack lsb-security_4.1+Debian11ubuntu8_amd64.deb ...
Unpacking lsb-security (4.1+Debian11ubuntu8) ...
dpkg: dependency problems prevent configuration of lsb-core:
lsb-core depends on lsb-invalid-mta (>= 4.1+Debian11ubuntu6) | mail-transport-agent; however:
Package lsb-invalid-mta is not installed.
Package mail-transport-agent is not installed.
lsb-core depends on at; however:
Package at is not installed.
lsb-core depends on m4; however:
Package m4 is not installed.
lsb-core depends on mailx | mailutils; however:
Package mailx is not installed.
Package mailutils is not installed.
lsb-core depends on pax; however:
Package pax is not installed.
lsb-core depends on alien (>= 8.36); however:
Package alien is not installed.
lsb-core depends on libc6-i386; however:
Package libc6-i386 is not installed.
lsb-core depends on lib32z1; however:
Package lib32z1 is not installed.

dpkg: error processing package lsb-core (--install):
dependency problems - leaving unconfigured
Setting up lsb-security (4.1+Debian11ubuntu8) ...
Processing triggers for man-db (2.7.5-1) ...
Errors were encountered while processing:

Now let fix this dependences issue by force installation:

sudo apt-get -f install

After this, install the DEB packages again:

sudo dpkg -i *.deb

This time it finished without error.

Install Google Earth:

Download the deb file from Google site
Pick the 64 bit .deb file.

Then install it:

sudo dpkg -i google-earth-stable_current_amd64.deb

That’s it. Now I can start the Google Earth from my desktop.

Panoramio blank picture

There is a problem: when you try to click on the Panaramio photo, all I got is a blank frame. Don’t worry, let’s fix it:

cd /opt/google/earth/free/
sudo wget
sudo tar xvf ge7.1.1.1580-0.x86_64-new-qt-libs-debian7-ubuntu12.tar.xz

Now I have Goole Earth on Ubuntu 16.04.

[Update] Fix another error

I noticed after Google Earth installed on my system, when I try to update my system I got warning message:

W: Signature by key 4CCA1EAF950CEE4AB83976DCA040830F7FAC5991 uses weak digest algorithm (SHA1)

This is because the Google Earth installer automatically installed and enabled a google-earth repository in the system. The purpose is to automatically update Google Earth if there is a new release. Unfortunately it seems the repository maintainer (Google) uses the weak SHA1 which Ubuntu/Debian abandoned.

So I have two choices here:

  1. Ignore this message. It won’t affect other update or installation. And it may let you update Google Earth in the future.
  2. Disable the google-earth repository. You won’t able to update Google Earth automatically after this. To disable it, excute this command:
    sed -e 's/^deb/#deb/' -i /etc/apt/sources.list.d/google-earth.list

Here I chose Option 2 for now.